We are continuing to work on a fix for this issue.
Posted Nov 18, 2025 - 09:26 EST
Identified
The third-party CDN used to speed page load times is experiencing operational issues. Access to our VR2 platform may be spotty based on your geographic region. This does not affect our platform's ability to send scheduled campaigns, but it may make it difficult to access our site.
Posted Nov 18, 2025 - 08:06 EST
This incident affected: Vertical Response (VR2) (Website) and Vertical Response (Classic) (Website).