Incident December 14
Incident Report for Vertical Response
Resolved
The problem had been corrected and changes have been made to prevent it from reoccurring.
Posted Dec 14, 2023 - 16:21 EST
Identified
There is a known problem preventing access to our VR2 platform.
Posted Dec 14, 2023 - 15:38 EST
This incident affected: Vertical Response (VR2) (Website).